利用packstack工具安装openstack的过程中,发生如下错误:

ERROR : Error appeared during Puppet run: 10.167.14.164_cinder.pp
Error: cinder type-create iscsi returned 1 instead of one of [0]

原因:
cinder组件在上一次的安装过程中已经创建了iscsi的类型

cinder type-list
+--------------------------------------+-------+-------------+-----------+
|                  ID                  |  Name | Description | Is_Public |
+--------------------------------------+-------+-------------+-----------+
| fb0eb8a8-2e74-41ce-a95b-754bfdd5124c | iscsi |      -      |    True   |
+--------------------------------------+-------+-------------+-----------+

解决方法:
删除即可:

cinder type-delete fb0eb8a8-2e74-41ce-a95b-754bfdd5124c
cinder type-list
+----+------+-------------+-----------+
| ID | Name | Description | Is_Public |
+----+------+-------------+-----------+
+----+------+-------------+-----------+